$re = '/.*\\\\([^\ ]+)/m';
$str = '\\\\D6-DC\\Users$\\name\\Profile\\Desktop\\New folder\\XXX-XX-XX-XXX OP1 RAN.NC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);