#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\w.*?)\[([^\]]*)\]"
Local $sString = "uploads/documents/home4.jpg[ " nosotros "," Somos una asociación civil sin fines de lucro, formada por padres y madres con hijos con problemas de audición, que nos hemos organizado a raíz de los problemas que enfrentamos día a día, por la falta de apoyo para la inclusión de nuestros hijos."] , uploads/documents/home4.jpg [" servicios ","Somos una asociación civil sin fines de lucro, formada por padres y madres con hijos con problemas de audición, que nos hemos organizado a raíz de los problemas que enfrentamos día a día, por la falta de apoyo para la inclusión de nuestros hijos."] ," & @CRLF & _
"" & @CRLF & _
"http://lorempixel.com/300/300 [" tecnologias ","Somos una asociación civil sin fines de lucro, formada por padres y madres con hijos con problemas de audición, que nos hemos organizado a raíz de los problemas que enfrentamos día a día, por la falta de apoyo para la inclusión de nuestros hijos."]" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")