const regex = /(\w.*?)\[([^\]]*)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w.*?)\\[([^\\]]*)\\]', 'g')
const str = `uploads/documents/home4.jpg[ " nosotros "," Somos una asociación civil sin fines de lucro, formada por padres y madres con hijos con problemas de audición, que nos hemos organizado a raíz de los problemas que enfrentamos día a día, por la falta de apoyo para la inclusión de nuestros hijos."] , uploads/documents/home4.jpg [" servicios ","Somos una asociación civil sin fines de lucro, formada por padres y madres con hijos con problemas de audición, que nos hemos organizado a raíz de los problemas que enfrentamos día a día, por la falta de apoyo para la inclusión de nuestros hijos."] ,
http://lorempixel.com/300/300 [" tecnologias ","Somos una asociación civil sin fines de lucro, formada por padres y madres con hijos con problemas de audición, que nos hemos organizado a raíz de los problemas que enfrentamos día a día, por la falta de apoyo para la inclusión de nuestros hijos."]
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}