using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test(?:Inputs|Vars)\.(?:(?=.*test(?:Inputs|Vars)\.)[^!=A-Z]+|(?!.*test(?:Inputs|Vars)\.)[^!=]+)";
string input = @"testInputs.abc_def.alpha=abc^ORtestVars.var23.nameISEMPTY^testInputs.alpha_bravo.more.otheroneCONTAINSsomething^testVars.anotherone!=abc^testVars.mYVar!=abc
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}