re = /test(?:Inputs|Vars)\.(?:(?=.*test(?:Inputs|Vars)\.)[^!=A-Z]+|(?!.*test(?:Inputs|Vars)\.)[^!=]+)/m
str = 'testInputs.abc_def.alpha=abc^ORtestVars.var23.nameISEMPTY^testInputs.alpha_bravo.more.otheroneCONTAINSsomething^testVars.anotherone!=abc^testVars.mYVar!=abc
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end