#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[0-2]\d|[3][0-1]|\d)\.(?:[0][1-9]|[1][0-2]|\d)\.\d*|\d*-(?:[0][1-9]|[1][0-2]|\d)-(?:[0-2]\d|[3][0-1]|\d))$"
Local $sString = "18.03.2018" & @CRLF & _
"20.10.1967" & @CRLF & _
"03.05.2002" & @CRLF & _
"3.5.2002" & @CRLF & _
"03.5.2002" & @CRLF & _
"3.05.2002" & @CRLF & _
"18.03.18" & @CRLF & _
"20.10.67" & @CRLF & _
"03.05.02" & @CRLF & _
"3.5.02" & @CRLF & _
"03.5.02" & @CRLF & _
"3.05.02" & @CRLF & _
"" & @CRLF & _
"2018-05-3" & @CRLF & _
"2018-06-03" & @CRLF & _
"1967-6-2" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"32.13.2001" & @CRLF & _
"15.15.2002" & @CRLF & _
"-1.03.3002" & @CRLF & _
"20.10.6a7" & @CRLF & _
"a20.10.67" & @CRLF & _
"20.10a.67"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")