re = /((?<=[^\.])\.{2}[^\.]|(?<=[^\.])\.{4,}[^\.])/m
str = 'Блин. Стоп
Блин.. Стоп
Блин... Стоп
Блин.... Стоп
Блин..... Стоп'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end