package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{3}\-[0-9]{7}\-[0-9]{2}$`)
var str = `123-1234567-12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}