re = /([[:alnum:]])\1{2,}/m
str = 'test111testaaatest777777testrrrrrrtest11testaatest'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end