using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(S)([BS](?=20-0)|[TM])(20)(-)([01])";
string input = @"SS20-0
SS20-1
ST20-0
ST20-1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}