$re = '/(S)([BS](?=20-0)|[TM])(20)(-)([01])/m';
$str = 'SS20-0
SS20-1
ST20-0
ST20-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);