const regex = new RegExp('[1-9]\\d{0,2}(?:,\\d{3}){2,}|[1-9]\\d{1,2},\\d{3}', 'gm')
const str = `"10,400,000","10,900,000","500,000","1,400,000","1,900,000,123,564"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}