#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)_(\w+)_\d+_\d+\.[^.]*$"
Local $sString = "Doc20191001119049_fotocontargasx_3962122_943000.jpg" & @CRLF & _
"Doc201810011052053_fotoAssicurazioneCartaceo_3962128_943000.jpg" & @CRLF & _
"Doc201910011214020_fotoesterna_ant_396024_947112.jpg" & @CRLF & _
"Doc201710071149010_foto_TargaMid_4007396_95010.jpg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")