re = /_(\w+)_\d+_\d+\.[^.]*$/m
str = 'Doc20191001119049_fotocontargasx_3962122_943000.jpg
Doc201810011052053_fotoAssicurazioneCartaceo_3962128_943000.jpg
Doc201910011214020_fotoesterna_ant_396024_947112.jpg
Doc201710071149010_foto_TargaMid_4007396_95010.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end