$re = '/\*\*(?:.+\*\*)*(.+)/m';
$str = 'abc ** this does not match ** but I guess this * bit does';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);