re = /^\+?998?\s?-?(90|91|93|94|95|98|99|33|97|71)\s?-?(\d{3})\s?-?(\d{2})\s?-?(\d{2})$/
str = '998903641905'
# Print the match result
str.match(re) do |match|
puts match.to_s
end