# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Initial commit|Merge [^\r\n]+|(?:(?<type>build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|BREAKING CHANGE)(?<scope>\(\w+\))?(?<breaking_change>!?): (?<summary>[\w -]+))(?<=\v\v){0,2}(?<body>[\w\s-]+)(?<footer>(?<=\v\v)(?<footer_token>[\w-]+): (?<footer_value>[\w -]+)|$)"
test_str = ("#1\n\n"
"build(Breaking): la asdf asdf asdf\n\n"
"asdfasdf asdf asdf\n"
"asdf\n"
"asdf\n"
"asdf\n\n"
"asdf\n"
"asdf\n\n"
"asdf\n\n"
"aef asdf asdf\n\n"
"#2\n\n"
"build(Breaking)!: la asdf asdf asdf\n\n"
"asdfasdf asdf asdf\n"
"asdf\n"
"asdf\n"
"asdf\n\n"
"asdf\n"
"asdf\n\n"
"asdf\n\n"
"aef asdf asdf\n\n"
"asdf-asdf: asdf asfd asfd asdf\n\n"
"#3\n\n"
"build(Breaking): asdfasdf\n\n"
"#4\n\n"
"build(Breaking): la asdf asdf asdf\n\n"
"asdfasdf asdf asdf\n"
"asdf\n"
"asdf\n"
"asdf\n\n"
"asdf\n"
"asdf\n\n"
"asdf\n\n"
"aef asdf asdf\n\n"
"#5\n\n"
"build(Breaking): la asdf asdf asdf\n\n"
"asdfasdf asdf asdf\n"
"asdf\n"
"asdf\n"
"asdf\n\n"
"asdf\n"
"asdf\n\n"
"asdf\n\n"
"aef asdf asdf\n"
"asdf-asdf: asdf")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.