import Foundation
let pattern = #"Initial commit|Merge [^\r\n]+|(?:(?<type>build|chore|ci|docs|feat|fix|perf|refactor|revert|style|test|BREAKING CHANGE)(?<scope>\(\w+\))?(?<breaking_change>!?): (?<summary>[\w -]+))(?<=\v\v){0,2}(?<body>[\w\s-]+)(?<footer>(?<=\v\v)(?<footer_token>[\w-]+): (?<footer_value>[\w -]+)|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
#1
build(Breaking): la asdf asdf asdf
asdfasdf asdf asdf
asdf
asdf
asdf
asdf
asdf
asdf
aef asdf asdf
#2
build(Breaking)!: la asdf asdf asdf
asdfasdf asdf asdf
asdf
asdf
asdf
asdf
asdf
asdf
aef asdf asdf
asdf-asdf: asdf asfd asfd asdf
#3
build(Breaking): asdfasdf
#4
build(Breaking): la asdf asdf asdf
asdfasdf asdf asdf
asdf
asdf
asdf
asdf
asdf
asdf
aef asdf asdf
#5
build(Breaking): la asdf asdf asdf
asdfasdf asdf asdf
asdf
asdf
asdf
asdf
asdf
asdf
aef asdf asdf
asdf-asdf: asdf
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)