#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[:blank:]"
Local $sString = "aaaaaa" & @CRLF & _
"bbbbbb" & @CRLF & _
"cccccc" & @CRLF & _
"h" & @CRLF & _
"hi" & @CRLF & _
"hii" & @CRLF & _
"hiii" & @CRLF & _
"hiiii" & @CRLF & _
"hiiiii" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz" & @CRLF & _
" \s" & @CRLF & _
"{}[]()^$+*?."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")