const regex = /(\w)\^(\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w)\\^(\\d)', 'gm')
const str = `e^3`;
const subst = `$1**$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);