import re
regex = re.compile(r"(\w)\^(\d)", flags=re.MULTILINE)
test_str = "e^3"
subst = "$1**$2"
result = regex.sub(subst, test_str)
if result:
print(result)