import re
regex = re.compile(r"\/\d{1,2}\b(?=[^\r\n\/]*$)", flags=re.MULTILINE)
test_str = ("ID Flag\n"
"P-MTP00197854/03 X\n"
"P-MTP00197868/02 X\n"
"P-MTP00197882/00 X\n"
"P-HMF00197730 \n"
"WI/B09/077094 \n"
"Q-MTP00197735 \n"
"Q-HMF00199313/0 X\n\n\n"
"Q-HMF/23/00199313/0 X")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")