$re = '/(?<=\/\/|\.)[^.]+\.[^.]+\/$/m';
$str = 'https://coinmarketcap.com/
https://www.buzzfeed.com/
https://www.refinery29.com/
https://www.businessinsider.com/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);