re = /(?<=\/\/|\.)[^.]+\.[^.]+\/$/m
str = 'https://coinmarketcap.com/
https://www.buzzfeed.com/
https://www.refinery29.com/
https://www.businessinsider.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end