package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^,]*LED[^,]*`)
var str = `Display: 27 in, VA, Viewing angles (H/V): 170 / 160, W-LED, 1920 x 1080 pixels
Display: 21.5 in, VA, Edge LED (Local Dimming), 1920 x 1080 pixels`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}