re = /[^,]*LED[^,]*/m
str = 'Display: 27 in, VA, Viewing angles (H/V): 170 / 160, W-LED, 1920 x 1080 pixels
Display: 21.5 in, VA, Edge LED (Local Dimming), 1920 x 1080 pixels'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end