const regex = /^[0-9]+[abAB]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-9]+[abAB]?$', 'gm')
const str = `1abbbaa434
25
15a
45B
2A
53b
96
A
a
B
b
B76
a34`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}