import re
regex = re.compile(r"^[0-9]+[abAB]?$", flags=re.MULTILINE)
test_str = ("1abbbaa434\n"
"25\n"
"15a\n"
"45B\n"
"2A\n"
"53b\n"
"96\n\n"
"A\n"
"a\n"
"B\n"
"b\n"
"B76\n"
"a34")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")