#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((http|https):\/\/)?([\/\w \.-]*)"
Local $sString = "https://stackoverflow.com/questions/3809401/url?test=1" & @CRLF & _
"http://stackoverflow.com/questions/3809401/url/?test=1" & @CRLF & _
"https://stackoverflow.com/questions/3809401url" & @CRLF & _
"http://stackoverflow.com?test=1" & @CRLF & _
"http://stackoverflow.com/" & @CRLF & _
"http://stackoverflow.com/test/" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")