import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((http|https):\\/\\/)?([\\/\\w \\.-]*)";
final String string = "https://stackoverflow.com/questions/3809401/url?test=1\n"
+ "http://stackoverflow.com/questions/3809401/url/?test=1\n"
+ "https://stackoverflow.com/questions/3809401url\n"
+ "http://stackoverflow.com?test=1\n"
+ "http://stackoverflow.com/\n"
+ "http://stackoverflow.com/test/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}