package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\D\d]+&&&`)
var str = `Текст 1&&&Текст 2&&&&&Текст 3&&&&Текст 4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}