$re = '/[\D\d]+&&&/';
$str = 'Текст 1&&&Текст 2&&&&&Текст 3&&&&Текст 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);