package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[[^\]]*\]\[(?<type>[^\]]+)`)
var str = `[2023-07-19T03:55:16,043][ERROR][o.o.s.i.DetectorIndexManagementService] [opensearch-cluster-master-2] info deleteOldIndices`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}