re = /^\[[^\]]*\]\[(?<type>[^\]]+)/m
str = '[2023-07-19T03:55:16,043][ERROR][o.o.s.i.DetectorIndexManagementService] [opensearch-cluster-master-2] info deleteOldIndices'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end