package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\*[\s\S]*?\*\/|([^\\:]|^)\/\/.*$`)
var str = `// fallback response. For more information contact support
channels=['channel1','channel2'];
/* i am some very long
long long long comment */
channels=['channel1','channel2'];
// comment 1
//comment 2
channels=['channel1','channel2'];`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}