package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^()\s]+|[()]`)
var str = `I don't like to eat Cici's food (it is true)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}