$re = '/[^()\s]+|[()]/';
$str = 'I don\'t like to eat Cici\'s food (it is true)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);