const regex = /\b\d+\.?\d*\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+\\.?\\d*\\b', 'g')
const str = `"12.3,Name1,3,4,Name2,35,Name3"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}