$re = '/\b\d+\.?\d*\b/';
$str = '"12.3,Name1,3,4,Name2,35,Name3"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);