#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=this|that|other)(?>\s*(?:(?(1)(?!))\bthis\b()|(?(2)(?!))\bthat\b()|(?(3)(?!))\bother\b()|(?(4)(?!))\b(.+?)\b|(?(5)(?!))\b(.+?)\b|(?(6)(?!))\b(.+?)\b|(?(7)(?!))\b(.+?)\b|(?(8)(?!))\b(.+?)\b|(?(9)(?!))\b(.+?)\b)\s*){3,9}?(?=\1\2\3)"
Local $sString = "looking for this and that and some other thing" & @CRLF & _
"that rod is longer than this other one" & @CRLF & _
"other than this, I have nothing" & @CRLF & _
"ignore multiple words not before this and that or other" & @CRLF & _
"this and that or other, followed by a bunch of words" & @CRLF & _
"" & @CRLF & _
"looking at this and A B C that some of other thing"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")