$re = '/(?=this|that|other)(?>\s*(?:(?(1)(?!))\bthis\b()|(?(2)(?!))\bthat\b()|(?(3)(?!))\bother\b()|(?(4)(?!))\b(.+?)\b|(?(5)(?!))\b(.+?)\b|(?(6)(?!))\b(.+?)\b|(?(7)(?!))\b(.+?)\b|(?(8)(?!))\b(.+?)\b|(?(9)(?!))\b(.+?)\b)\s*){3,9}?(?=\1\2\3)/m';
$str = 'looking for this and that and some other thing
that rod is longer than this other one
other than this, I have nothing
ignore multiple words not before this and that or other
this and that or other, followed by a bunch of words
looking at this and A B C that some of other thing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);