#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+\s+.+?\s+(\d+,\d{2})\s"
Local $sString = " Bestellung" & @CRLF & _
"" & @CRLF & _
" Information" & @CRLF & _
"" & @CRLF & _
"Lieferantenanschrift" & @CRLF & _
"" & @CRLF & _
"Firma Belegnummer 7700085038" & @CRLF & _
"" & @CRLF & _
"Liefer GmbH Datum 13.07.2017" & @CRLF & _
"" & @CRLF & _
"Musterstr. 9 Seite 1 von 3" & @CRLF & _
"" & @CRLF & _
"D-123456 Musterhausen Lieferantennummer 10005750" & @CRLF & _
"" & @CRLF & _
"Fax: +49451300966666 Währung EUR" & @CRLF & _
"" & @CRLF & _
"Anlieferanschrift Einkäufer Willi Wichtig" & @CRLF & _
"" & @CRLF & _
"Kaufhausen GmbH Telefon +49 4941 9777 777" & @CRLF & _
"" & @CRLF & _
"Willi Schmalhans Fax-Nr +49 4941 977 7777" & @CRLF & _
"" & @CRLF & _
"Kaufstraße 0815 e-Mail willi.schmalhans@kaufhausen.de" & @CRLF & _
"" & @CRLF & _
"D-123456 Konkursstadt" & @CRLF & _
"" & @CRLF & _
"Rechnungsadresse" & @CRLF & _
"" & @CRLF & _
"Firma" & @CRLF & _
"" & @CRLF & _
"Kaufhausen GmbH" & @CRLF & _
"" & @CRLF & _
"Ausverkaufstr. 13" & @CRLF & _
"" & @CRLF & _
"D-123456 Konkursstadt" & @CRLF & _
"" & @CRLF & _
"UST-ID: DE111111111" & @CRLF & _
"" & @CRLF & _
"Zahlungsbedingungen: innerhalb 30 Tage 3% Skonto / 60 Tage netto Liefertermin: 18.07.2017" & @CRLF & _
"" & @CRLF & _
"Lieferbedingungen: DAP Anlieferadresse" & @CRLF & _
"" & @CRLF & _
"Für Fragen zu Bedingungen des Rahmenvertrages, wenden Sie sich bitte an den verantwortlichen Materialgruppen-Einkäufer." & @CRLF & _
"" & @CRLF & _
"Bei Abstimmungsbedarf zu dieser vorliegenden Bestellung steht Ihnen der o.g. Ansprechpartner gerne zur Verfügung." & @CRLF & _
"" & @CRLF & _
"Hiermit bestellen wir gemäß der Incoterms® 2010 und unseren Einkaufsbedingungen vom 01.10.2015, die Sie im Internet unter" & @CRLF & _
"" & @CRLF & _
"www.kaufhausen.de\Einkaufsbedingungen einsehen können." & @CRLF & _
"" & @CRLF & _
"Bitte achten Sie auf das Pflichtenheft für Lieferanten - nur(!) relevant für die LKW Warenanlieferung in das Industriegebiet Nord in" & @CRLF & _
"" & @CRLF & _
"Konkursstadt" & @CRLF & _
"" & @CRLF & _
"Nur so können die Anlieferverkehre weiterhin optimiert und die Wartezeiten entsprechend verkürzt werden!" & @CRLF & _
"" & @CRLF & _
"Die Meldestelle ist => KAUFHAUSEN Logistikplatz: Elsterweg 15, 123456 Konkursstadt" & @CRLF & _
"" & @CRLF & _
"Position Materialbeschreibung Menge Einheit Preis pro Einheit Nettobetrag" & @CRLF & _
"" & @CRLF & _
"10 M.Gewindeb. M D371B HSSEM10 VA 5,00 ST 10,92 / 1 ST 54,60" & @CRLF & _
"" & @CRLF & _
" FORUM" & @CRLF & _
"" & @CRLF & _
" Ihre Materialnummer: 4214404285" & @CRLF & _
"" & @CRLF & _
" Durchgangsloch-Maschinengewindebohrer, 2 x D Durchgangsloch, Oberfläche dampfbehandelt # Metrisches" & @CRLF & _
"" & @CRLF & _
" ISO-Gewinde DIN 13 # Form B mitSchälanschnitt (3,5#5 Gang) # Gerade genutet # Toleranz ISO 2 6H # 2 x D" & @CRLF & _
"" & @CRLF & _
" Durchgangsloch" & @CRLF & _
"" & @CRLF & _
" Kostenstelle : 365310" & @CRLF & _
"" & @CRLF & _
"................................................................................................................................................................................................................................................" & @CRLF & _
"" & @CRLF & _
" Kaufhausen GmbH# Sitz und Registergericht: Konkursstadt # Registernummer: HRB 1111 # Geschäftsführer: Dipl.Ing. D.Katzenberger" & @CRLF & _
"" & @CRLF & _
" Bankverbindung: Heassische Landesbank: IBAN: DE99 9999 9999 9999 9999 30 # BIC: WELA DE DD # USt-ID-Nr. DE 111111111" & @CRLF & _
"Kaufhausen GmbH# Ausverkaufstr. 13 # 123456 Konkursstadt Bestellung" & @CRLF & _
"" & @CRLF & _
" Information" & @CRLF & _
"" & @CRLF & _
"Lieferantenanschrift Belegnummer 7700085038" & @CRLF & _
"" & @CRLF & _
"Firma Datum 13.07.2017" & @CRLF & _
"" & @CRLF & _
"Liefer GmbH Seite 2 von 3" & @CRLF & _
"" & @CRLF & _
"Musterstr. 9" & @CRLF & _
"" & @CRLF & _
"D-123456 Musterhausen" & @CRLF & _
"" & @CRLF & _
"Fax: +49451300966666" & @CRLF & _
"" & @CRLF & _
"Position Materialbeschreibung Menge Einheit Preis pro Einheit Nettobetrag" & @CRLF & _
"" & @CRLF & _
"20 M.Gewindeb. M D371B HSSEM8 VA FORUM 5,00 ST 9,05 / 1 ST 45,25" & @CRLF & _
"" & @CRLF & _
" Ihre Materialnummer: 4214404282" & @CRLF & _
"" & @CRLF & _
" Durchgangsloch-Maschinengewindebohrer, 2 x D Durchgangsloch, Oberfläche dampfbehandelt # Metrisches" & @CRLF & _
"" & @CRLF & _
" ISO-Gewinde DIN 13 # Form B mitSchälanschnitt (3,5#5 Gang) # Gerade genutet # Toleranz ISO 2 6H # 2 x D" & @CRLF & _
"" & @CRLF & _
" Durchgangsloch" & @CRLF & _
"" & @CRLF & _
" Kostenstelle : 365310" & @CRLF & _
"" & @CRLF & _
"................................................................................................................................................................................................................................................" & @CRLF & _
"" & @CRLF & _
"30 M.Gewindeb. M D371B HSSEM6 VA FORUM 5,00 ST 7,49 / 1 ST 37,45" & @CRLF & _
"" & @CRLF & _
" Ihre Materialnummer: 4214404279" & @CRLF & _
"" & @CRLF & _
" Durchgangsloch-Maschinengewindebohrer, 2 x D Durchgangsloch, Oberfläche dampfbehandelt # Metrisches" & @CRLF & _
"" & @CRLF & _
" ISO-Gewinde DIN 13 # Form B mitSchälanschnitt (3,5#5 Gang) # Gerade genutet # Toleranz ISO 2 6H # 2 x D" & @CRLF & _
"" & @CRLF & _
" Durchgangsloch" & @CRLF & _
"" & @CRLF & _
" Kostenstelle : 365310" & @CRLF & _
"" & @CRLF & _
"................................................................................................................................................................................................................................................" & @CRLF & _
"" & @CRLF & _
" _________________" & @CRLF & _
"" & @CRLF & _
" Gesamtnettowert EUR 137,30" & @CRLF & _
"" & @CRLF & _
" _________________" & @CRLF & _
"" & @CRLF & _
" Kaufhausen GmbH# Sitz und Registergericht: Konkursstadt # Registernummer: HRB 1111 # Geschäftsführer: Dipl.Ing. D.Katzenberger" & @CRLF & _
"" & @CRLF & _
" Bankverbindung: Hessische Landesbank: IBAN: DE99 9999 9999 9999 9999 30 # BIC: WELA DE DD # USt-ID-Nr. DE 111111111" & @CRLF & _
"Kaufhausen GmbH# Ausverkaufstr. 13 # 123456 Konkursstadt Bestellung" & @CRLF & _
"" & @CRLF & _
" Information" & @CRLF & _
"" & @CRLF & _
"Lieferantenanschrift Belegnummer 7700085038" & @CRLF & _
"" & @CRLF & _
"Firma Datum 13.07.2017" & @CRLF & _
"" & @CRLF & _
"Liefer GmbH Seite 3 von 3" & @CRLF & _
"" & @CRLF & _
"Musterstr. 9" & @CRLF & _
"" & @CRLF & _
"D-123456 Musterhausen" & @CRLF & _
"" & @CRLF & _
"Fax: +49451300966666" & @CRLF & _
"" & @CRLF & _
" Sehr geehrte Damen und Herren," & @CRLF & _
"" & @CRLF & _
" um den Bestellprozess reibungslos abwickeln zu können, beachten Sie bitte die folgenden Punkte." & @CRLF & _
"" & @CRLF & _
" Bitte notieren Sie auf jeglichem Schriftverkehr (z.B. Lieferschein, Rechnungen #) unsere Bestellnummer ." & @CRLF & _
"" & @CRLF & _
" Die Rechnungs- und Lieferanschrift kann abweichend voneinander sein # achten Sie bitte auf die Richtigkeit." & @CRLF & _
"" & @CRLF & _
" Der genannte Liefertermin ist einzuhalten, bei eventuell auftretenden Lieferverzögerungen ist uns umgehend Bericht zu erstatten." & @CRLF & _
"" & @CRLF & _
" Jeglicher Abweichung bedarf einer schriftlichen Auftragsbestätigung." & @CRLF & _
"" & @CRLF & _
" Aus Gründen der rationellen Auftragsbearbeitung bitten wir , von einer ausführlichen Auftragsbestätigung abzusehen und uns" & @CRLF & _
"" & @CRLF & _
" stattdessen die Annahme dieser Bestellung durch die Rücksendung einer rechtsverbindlichen von Ihnen unterschriebenen Kopie" & @CRLF & _
"" & @CRLF & _
" dieser Bestellung zu bestätigen." & @CRLF & _
"" & @CRLF & _
" Ihre Bestätigungsnummer:__________________" & @CRLF & _
"" & @CRLF & _
" _______________, den __________ _____________________" & @CRLF & _
"" & @CRLF & _
" Zwecks Fragen oder Anmerkungen melden Sie sich gerne bei dem Ihn bekannten Facheinkäufer" & @CRLF & _
"" & @CRLF & _
" Mit freundlichen Grüßen" & @CRLF & _
"" & @CRLF & _
" KAUFHAUSEN GmbH" & @CRLF & _
"" & @CRLF & _
" - diese Bestellung ist ohne Unterschrift gültig -" & @CRLF & _
"" & @CRLF & _
" Kaufhausen GmbH# Sitz und Registergericht: Konkursstadt # Registernummer: HRB 1111 # Geschäftsführer: Dipl.Ing. D.Katzenberger" & @CRLF & _
"" & @CRLF & _
" Bankverbindung: Hessische Landesbank: IBAN: DE99 9999 9999 9999 9999 30 # BIC: WELA DE DD # USt-ID-Nr. DE 111111111" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")