# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d+\s+.+?\s+(\d+,\d{2})\s"
test_str = (" Bestellung\n\n"
" Information\n\n"
"Lieferantenanschrift\n\n"
"Firma Belegnummer 7700085038\n\n"
"Liefer GmbH Datum 13.07.2017\n\n"
"Musterstr. 9 Seite 1 von 3\n\n"
"D-123456 Musterhausen Lieferantennummer 10005750\n\n"
"Fax: +49451300966666 Währung EUR\n\n"
"Anlieferanschrift Einkäufer Willi Wichtig\n\n"
"Kaufhausen GmbH Telefon +49 4941 9777 777\n\n"
"Willi Schmalhans Fax-Nr +49 4941 977 7777\n\n"
"Kaufstraße 0815 e-Mail willi.schmalhans@kaufhausen.de\n\n"
"D-123456 Konkursstadt\n\n"
"Rechnungsadresse\n\n"
"Firma\n\n"
"Kaufhausen GmbH\n\n"
"Ausverkaufstr. 13\n\n"
"D-123456 Konkursstadt\n\n"
"UST-ID: DE111111111\n\n"
"Zahlungsbedingungen: innerhalb 30 Tage 3% Skonto / 60 Tage netto Liefertermin: 18.07.2017\n\n"
"Lieferbedingungen: DAP Anlieferadresse\n\n"
"Für Fragen zu Bedingungen des Rahmenvertrages, wenden Sie sich bitte an den verantwortlichen Materialgruppen-Einkäufer.\n\n"
"Bei Abstimmungsbedarf zu dieser vorliegenden Bestellung steht Ihnen der o.g. Ansprechpartner gerne zur Verfügung.\n\n"
"Hiermit bestellen wir gemäß der Incoterms® 2010 und unseren Einkaufsbedingungen vom 01.10.2015, die Sie im Internet unter\n\n"
"www.kaufhausen.de\\Einkaufsbedingungen einsehen können.\n\n"
"Bitte achten Sie auf das Pflichtenheft für Lieferanten - nur(!) relevant für die LKW Warenanlieferung in das Industriegebiet Nord in\n\n"
"Konkursstadt\n\n"
"Nur so können die Anlieferverkehre weiterhin optimiert und die Wartezeiten entsprechend verkürzt werden!\n\n"
"Die Meldestelle ist => KAUFHAUSEN Logistikplatz: Elsterweg 15, 123456 Konkursstadt\n\n"
"Position Materialbeschreibung Menge Einheit Preis pro Einheit Nettobetrag\n\n"
"10 M.Gewindeb. M D371B HSSEM10 VA 5,00 ST 10,92 / 1 ST 54,60\n\n"
" FORUM\n\n"
" Ihre Materialnummer: 4214404285\n\n"
" Durchgangsloch-Maschinengewindebohrer, 2 x D Durchgangsloch, Oberfläche dampfbehandelt # Metrisches\n\n"
" ISO-Gewinde DIN 13 # Form B mitSchälanschnitt (3,5#5 Gang) # Gerade genutet # Toleranz ISO 2 6H # 2 x D\n\n"
" Durchgangsloch\n\n"
" Kostenstelle : 365310\n\n"
"................................................................................................................................................................................................................................................\n\n"
" Kaufhausen GmbH# Sitz und Registergericht: Konkursstadt # Registernummer: HRB 1111 # Geschäftsführer: Dipl.Ing. D.Katzenberger\n\n"
" Bankverbindung: Heassische Landesbank: IBAN: DE99 9999 9999 9999 9999 30 # BIC: WELA DE DD # USt-ID-Nr. DE 111111111\n"
"Kaufhausen GmbH# Ausverkaufstr. 13 # 123456 Konkursstadt Bestellung\n\n"
" Information\n\n"
"Lieferantenanschrift Belegnummer 7700085038\n\n"
"Firma Datum 13.07.2017\n\n"
"Liefer GmbH Seite 2 von 3\n\n"
"Musterstr. 9\n\n"
"D-123456 Musterhausen\n\n"
"Fax: +49451300966666\n\n"
"Position Materialbeschreibung Menge Einheit Preis pro Einheit Nettobetrag\n\n"
"20 M.Gewindeb. M D371B HSSEM8 VA FORUM 5,00 ST 9,05 / 1 ST 45,25\n\n"
" Ihre Materialnummer: 4214404282\n\n"
" Durchgangsloch-Maschinengewindebohrer, 2 x D Durchgangsloch, Oberfläche dampfbehandelt # Metrisches\n\n"
" ISO-Gewinde DIN 13 # Form B mitSchälanschnitt (3,5#5 Gang) # Gerade genutet # Toleranz ISO 2 6H # 2 x D\n\n"
" Durchgangsloch\n\n"
" Kostenstelle : 365310\n\n"
"................................................................................................................................................................................................................................................\n\n"
"30 M.Gewindeb. M D371B HSSEM6 VA FORUM 5,00 ST 7,49 / 1 ST 37,45\n\n"
" Ihre Materialnummer: 4214404279\n\n"
" Durchgangsloch-Maschinengewindebohrer, 2 x D Durchgangsloch, Oberfläche dampfbehandelt # Metrisches\n\n"
" ISO-Gewinde DIN 13 # Form B mitSchälanschnitt (3,5#5 Gang) # Gerade genutet # Toleranz ISO 2 6H # 2 x D\n\n"
" Durchgangsloch\n\n"
" Kostenstelle : 365310\n\n"
"................................................................................................................................................................................................................................................\n\n"
" _________________\n\n"
" Gesamtnettowert EUR 137,30\n\n"
" _________________\n\n"
" Kaufhausen GmbH# Sitz und Registergericht: Konkursstadt # Registernummer: HRB 1111 # Geschäftsführer: Dipl.Ing. D.Katzenberger\n\n"
" Bankverbindung: Hessische Landesbank: IBAN: DE99 9999 9999 9999 9999 30 # BIC: WELA DE DD # USt-ID-Nr. DE 111111111\n"
"Kaufhausen GmbH# Ausverkaufstr. 13 # 123456 Konkursstadt Bestellung\n\n"
" Information\n\n"
"Lieferantenanschrift Belegnummer 7700085038\n\n"
"Firma Datum 13.07.2017\n\n"
"Liefer GmbH Seite 3 von 3\n\n"
"Musterstr. 9\n\n"
"D-123456 Musterhausen\n\n"
"Fax: +49451300966666\n\n"
" Sehr geehrte Damen und Herren,\n\n"
" um den Bestellprozess reibungslos abwickeln zu können, beachten Sie bitte die folgenden Punkte.\n\n"
" Bitte notieren Sie auf jeglichem Schriftverkehr (z.B. Lieferschein, Rechnungen #) unsere Bestellnummer .\n\n"
" Die Rechnungs- und Lieferanschrift kann abweichend voneinander sein # achten Sie bitte auf die Richtigkeit.\n\n"
" Der genannte Liefertermin ist einzuhalten, bei eventuell auftretenden Lieferverzögerungen ist uns umgehend Bericht zu erstatten.\n\n"
" Jeglicher Abweichung bedarf einer schriftlichen Auftragsbestätigung.\n\n"
" Aus Gründen der rationellen Auftragsbearbeitung bitten wir , von einer ausführlichen Auftragsbestätigung abzusehen und uns\n\n"
" stattdessen die Annahme dieser Bestellung durch die Rücksendung einer rechtsverbindlichen von Ihnen unterschriebenen Kopie\n\n"
" dieser Bestellung zu bestätigen.\n\n"
" Ihre Bestätigungsnummer:__________________\n\n"
" _______________, den __________ _____________________\n\n"
" Zwecks Fragen oder Anmerkungen melden Sie sich gerne bei dem Ihn bekannten Facheinkäufer\n\n"
" Mit freundlichen Grüßen\n\n"
" KAUFHAUSEN GmbH\n\n"
" - diese Bestellung ist ohne Unterschrift gültig -\n\n"
" Kaufhausen GmbH# Sitz und Registergericht: Konkursstadt # Registernummer: HRB 1111 # Geschäftsführer: Dipl.Ing. D.Katzenberger\n\n"
" Bankverbindung: Hessische Landesbank: IBAN: DE99 9999 9999 9999 9999 30 # BIC: WELA DE DD # USt-ID-Nr. DE 111111111\n"
"")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.