package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\p{L}\p{N}]`)
var str = `hey(w)orld(y)es(t1)hat's(m)y(s)tudent.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}