$re = '/[^\p{L}\p{N}]/u';
$str = 'hey(w)orld(y)es(t1)hat\'s(m)y(s)tudent.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;