$re = '/"(?:(?!=\\\\").)+?[^\\\\]"/m';
$str = 'here is a "test" of the "Double quote\\" system"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);