re = /"(?:(?!=\\").)+?[^\\]"/m
str = 'here is a "test" of the "Double quote\\" system"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end