package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$`)
var str = ` John Smith, Jr.
Winn Thomas
Mary 3llen Jones
Clyde Franklin, III
wallace firt, the second
wimbobimbo ff , VIVIVVVVIIIVIIVVI
s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}