import re
regex = re.compile(r"^([A-Z]|[a-z]|\s)+(,\s*(Jr\.|Sr\.|[IV]*))?$", flags=re.MULTILINE)
test_str = (" John Smith, Jr.\n"
"Winn Thomas\n"
" Mary 3llen Jones \n"
"Clyde Franklin, III\n"
"wallace firt, the second\n"
"wimbobimbo ff , VIVIVVVVIIIVIIVVI\n"
"s f asdf s dfFASFSf dsf saf sFD s faS fdy t sg , Sr.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")