use strict;
my $str = '#### v2
START MATCH
Text explaning things and stuff.
This has to be matched.
END MATCH
#### v1
Do not match this part (or anything
below "END MATCH" part).
#### v0
Do not match this either.';
my $regex = qr/(?s)\#+\sv2.*?(?=\s*(?:\#+|$))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}